summaryrefslogtreecommitdiff
path: root/libre/grub/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2019-08-12 21:24:02 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2019-08-12 21:24:02 -0500
commitcde9927bd1b43591a7dffa9fbabd3749c0075ae2 (patch)
tree15052c95abeff2f5fc5802038cab2fbb5cf82cc6 /libre/grub/PKGBUILD
parentf46b6b151ea041e4d864add566a164fb1639bcef (diff)
grub-2:2.04-2.par1: updating version
Diffstat (limited to 'libre/grub/PKGBUILD')
-rw-r--r--libre/grub/PKGBUILD258
1 files changed, 128 insertions, 130 deletions
diff --git a/libre/grub/PKGBUILD b/libre/grub/PKGBUILD
index c87d49a0a..4e90e1524 100644
--- a/libre/grub/PKGBUILD
+++ b/libre/grub/PKGBUILD
@@ -18,51 +18,54 @@ _IA32_XEN_IN_ARCH_X64='1'
## '1' to enable EMU build (x86_64 and i686 only), "0" to disable
_GRUB_EMU_BUILD='0'
-_GRUB_EXTRAS_COMMIT=f2a079441939eee7251bf141986cdd78946e1d20
+_GRUB_EXTRAS_COMMIT="136763a4cc9ca3a4f59d05b79eede2159d6f441e"
+_GNULIB_COMMIT="9ce9be2ef0cb1180e35dfe9dfbbe90d774b374bd"
+_UNIFONT_VER="12.1.02"
-_UNIFONT_VER='11.0.02'
+[[ "${CARCH}" = "armv7h" ]] && _EFI_ARCH="arm"
+[[ "${CARCH}" = "x86_64" ]] && _EFI_ARCH="x86_64"
+[[ "${CARCH}" = "i686" ]] && _EFI_ARCH="i386"
-[[ "${CARCH}" = 'armv7h' ]] && _EFI_ARCH='arm'
-[[ "${CARCH}" = 'x86_64' ]] && _EFI_ARCH='x86_64'
-[[ "${CARCH}" = 'i686' ]] && _EFI_ARCH='i386'
+[[ "${CARCH}" = "x86_64" ]] && _XEN_ARCH="x86_64"
+[[ "${CARCH}" = "i686" ]] && _XEN_ARCH="i386"
-[[ "${CARCH}" = 'x86_64' ]] && _XEN_ARCH='x86_64'
-[[ "${CARCH}" = 'i686' ]] && _XEN_ARCH='i386'
-
-[[ "${CARCH}" = 'armv7h' ]] && _EMU_ARCH='arm'
-[[ "${CARCH}" = 'x86_64' ]] && _EMU_ARCH='x86_64'
-[[ "${CARCH}" = 'i686' ]] && _EMU_ARCH='i386'
+[[ "${CARCH}" = "armv7h" ]] && _EMU_ARCH="arm"
+[[ "${CARCH}" = "x86_64" ]] && _EMU_ARCH="x86_64"
+[[ "${CARCH}" = "i686" ]] && _EMU_ARCH="i386"
pkgbase='grub'
pkgname=('grub')
[[ $CARCH = armv7h ]] && pkgname+=('grub-am335x_bone' 'grub-udoo' 'grub-omap3_beagle'
'grub-omap3_beagle_xm' 'grub-omap3_beagle_xm_ab')
pkgdesc='GNU GRand Unified Bootloader (2), (Parabola rebranded)'
-pkgver='2.02'
-pkgrel='8.par1'
-epoch='2'
+_pkgver=2.04
+pkgver=${_pkgver/-/}
+pkgrel=2
+pkgrel+=.par1
+epoch=2
url='https://www.gnu.org/software/grub/'
-arch=('x86_64' 'i686' 'armv7h')
+arch=('x86_64')
+arch+=('i686' 'armv7h')
license=('GPL3')
backup=('etc/default/grub'
'etc/grub.d/40_custom')
install="${pkgname}.install"
options=('!makeflags')
-depends=('sh' 'xz' 'gettext' 'device-mapper')
+
makedepends=('git' 'rsync' 'xz' 'freetype2' 'ttf-dejavu' 'python' 'autogen'
'texinfo' 'help2man' 'gettext' 'device-mapper' 'fuse')
+depends=('sh' 'xz' 'gettext' 'device-mapper')
+optdepends=('freetype2: For grub-mkfont usage'
+ 'fuse: For grub-mount usage')
if [[ "${CARCH}" = 'x86_64' ]] && [[ "${_XEN}" = '1' ]]; then
makedepends+=('xen')
fi
-if [[ "${_GRUB_EMU_BUILD}" = '1' ]]; then
+if [[ "${_GRUB_EMU_BUILD}" = "1" ]]; then
makedepends+=('libusbx' 'sdl')
fi
-optdepends=('freetype2: For grub-mkfont usage'
- 'fuse: For grub-mount usage')
-
if [[ "${CARCH}" = 'x86_64' ]] || [[ "${CARCH}" = 'i686' ]]; then
provides=('grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}")
conflicts=('grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}" 'grub-legacy' 'grub-parabola')
@@ -73,17 +76,16 @@ elif [[ "${CARCH}" = 'armv7h' ]]; then
replaces=('grub-common' 'grub-emu' "grub-efi-${_EFI_ARCH}")
fi
-source=("https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz"{,.sig}
- "https://git.savannah.nongnu.org/cgit/grub-extras.git/snapshot/grub-extras-${_GRUB_EXTRAS_COMMIT}.tar.gz"
+validpgpkeys=('E53D497F3FA42AD8C9B4D1E835A93B74E82E4209' # Vladimir 'phcoder' Serbinenko <phcoder@gmail.com>
+ 'BE5C23209ACDDACEB20DB0A28C8189F1988C2166' # Daniel Kiper <dkiper@net-space.pl>
+ '95D2E9AB8740D8046387FD151A09227B1F435A33') #Paul Hardy
+
+source=("git+https://git.savannah.gnu.org/git/grub.git#tag=grub-${_pkgver}?signed"
+ "git+https://git.savannah.gnu.org/git/grub-extras.git#commit=${_GRUB_EXTRAS_COMMIT}"
+ "git+https://git.savannah.gnu.org/git/gnulib.git#commit=${_GNULIB_COMMIT}"
"https://ftp.gnu.org/gnu/unifont/unifont-${_UNIFONT_VER}/unifont-${_UNIFONT_VER}.bdf.gz"{,.sig}
'0003-10_linux-20_linux_xen-detect-parabola-initramfs.patch'
'0004-add-GRUB_COLOR_variables.patch'
- '0005-Allow_GRUB_to_mount_ext234_filesystems_that_have_the_encryption_feature.patch'
- '0006-tsc-Change-default-tsc-calibration-method-to-pmtimer-on-EFI-systems.patch'
- '0007-grub-mkconfig_10_linux_Support_multiple_early_initrd_images.patch'
- '0008-Fix-packed-not-aligned-error-on-GCC-8.patch'
- '0009-xfs-Accept-filesystem-with-sparse-inodes.patch'
- '0010-relocation.patch'
'grub.default'
'0003-10_linux-20_linux_xen-detect-am335x_bone+am335x_boneblack-devicetree-file.patch'
'0003-10_linux-20_linux_xen-detect-omap3_beagle-devicetree-file.patch'
@@ -92,20 +94,14 @@ source=("https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz"{,.sig}
'0003-10_linux-20_linux_xen-detect-udoo-devicetree-file.patch'
'0003-10_linux-20_linux_xen-rebrand-free-distros.patch')
-sha256sums=('810b3798d316394f94096ec2797909dbf23c858e48f7b3830826b8daa06b7b0f'
+sha256sums=('SKIP'
+ 'SKIP'
'SKIP'
- '2844601914cea6b1231eca0104853a93c4d67a5209933a0766f1475953300646'
- 'a7ea9ca4f6dcb59377d978194835ede669457069256184f86d46ab5b863c56e6'
+ '04d652be1e28a6d464965c75c71ac84633085cd0960c2687466651c34c94bd89'
'SKIP'
'3f68a78ecba0284b9d39af60431236cb2ebc8547d3dc1fb26a1ac7a6b9afbbc7'
'a5198267ceb04dceb6d2ea7800281a42b3f91fd02da55d2cc9ea20d47273ca29'
- '535422c510a050d41efe7720dbe54de29e04bdb8f86fd5aea5feb0b24f7abe46'
- 'c38f2b2caae33008b35a37d8293d8bf13bf6fd779a4504925da1837fd007aeb5'
- 'e43566c4fe3b1b87e677167323d4716b82ac0810410a9d8dc7fbf415c8db2b8a'
- 'e84b8de569c7e6b73263758c35cf95c6516fde85d4ed451991427864f6a4e5a8'
- 'fcd5a626d4af33665d041ce42df813f1f198d8230ea186481b155a5b676f3b87'
- '51562fa1016c54567dbf42a86c0cfc902372ab579bbee17879a81aff09b76b99'
- '959f3d8d65d9504df798924554c3de0e92dfcd39e087b099a5f5e0a9b7885102'
+ 'c700a3a2e0bdb47620a78b454aaa4bbf52989102eb47b08672240192e91b2a57'
'9ece1db537a989ce4dc55ece471883e19b8ab16902f8c4feb68436c3b5700f71'
'de71452b9b0fbfb08ea742e9fa217ab34fddf6312452f155fb9d82ebf1c024a5'
'222da944b4af43a1d86be0e3d91f2e1a82324fa51c7ad36cc25246ffa3739ab1'
@@ -113,8 +109,8 @@ sha256sums=('810b3798d316394f94096ec2797909dbf23c858e48f7b3830826b8daa06b7b0f'
'6584a0dda9dbf6d70dbdfba619abbb628b1a092bd61d6d05e462d6771354223b'
'7374137d183957ec8834ce749163c9fa98ff8ee61bbb74b0b38e29daf93857a4')
-validpgpkeys=('E53D497F3FA42AD8C9B4D1E835A93B74E82E4209' # Vladimir 'phcoder' Serbinenko <phcoder@gmail.com>
- '95D2E9AB8740D8046387FD151A09227B1F435A33') #Paul Hardy
+_backports=(
+)
_configure_options=(
FREETYPE="pkg-config freetype2"
@@ -139,63 +135,52 @@ _configure_options=(
)
prepare() {
- cd "${srcdir}/grub-${pkgver}/"
+ cd "${srcdir}/grub/"
- echo 'Patch to detect of Parabola GNU/Linux-libre initramfs images by grub-mkconfig...'
+ echo "Apply backports..."
+ local _c
+ for _c in "${_backports[@]}"; do
+ git log --oneline -1 "${_c}"
+ git cherry-pick -n "${_c}"
+ done
+
+ echo "Patch to detect of Parabola GNU/Linux-libre initramfs images by grub-mkconfig..."
patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-parabola-initramfs.patch"
- echo 'Patch to enable GRUB_COLOR_* variables in grub-mkconfig...'
+ echo "Patch to enable GRUB_COLOR_* variables in grub-mkconfig..."
## Based on http://lists.gnu.org/archive/html/grub-devel/2012-02/msg00021.html
patch -Np1 -i "${srcdir}/0004-add-GRUB_COLOR_variables.patch"
- echo "Patch to allow GRUB to mount ext2/3/4 filesystems that have the encryption feature..."
- patch -Np1 -i "${srcdir}/0005-Allow_GRUB_to_mount_ext234_filesystems_that_have_the_encryption_feature.patch"
-
- echo "Patch to change default tsc calibration method to pmtimer on EFI systems..."
- patch -Np1 -i "${srcdir}/0006-tsc-Change-default-tsc-calibration-method-to-pmtimer-on-EFI-systems.patch"
-
- echo "Patch to Support multiple early initrd images..."
- patch -Np1 -i "${srcdir}/0007-grub-mkconfig_10_linux_Support_multiple_early_initrd_images.patch"
-
- echo "Patch to fix packed-not-aligned error on GCC 8..."
- patch -Np1 -i "${srcdir}/0008-Fix-packed-not-aligned-error-on-GCC-8.patch"
-
- echo "Patch xfs: Accept filesystem with sparse inodes..."
- patch -Np1 -i "${srcdir}/0009-xfs-Accept-filesystem-with-sparse-inodes.patch"
-
- echo "Patch x86-64: Treat R_X86_64_PLT32 as R_X86_64_PC32..."
- patch -Np1 -i "${srcdir}/0010-relocation.patch"
-
- echo 'Fix DejaVuSans.ttf location so that grub-mkfont can create *.pf2 files for starfield theme...'
+ echo "Fix DejaVuSans.ttf location so that grub-mkfont can create *.pf2 files for starfield theme..."
sed 's|/usr/share/fonts/dejavu|/usr/share/fonts/dejavu /usr/share/fonts/TTF|g' -i "configure.ac"
- echo 'Rebranding for some free distros...'
+ echo "Rebranding for some free distros..."
patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-rebrand-free-distros.patch"
echo "Fix mkinitcpio 'rw' FS#36275..."
sed 's| ro | rw |g' -i "util/grub.d/10_linux.in"
- echo 'Pull in latest language files...'
+ echo "Pull in latest language files..."
./linguas.sh
- echo 'Remove not working langs which need LC_ALL=C.UTF-8...'
+ echo "Remove not working langs which need LC_ALL=C.UTF-8..."
sed -e 's#en@cyrillic en@greek##g' -i "po/LINGUAS"
echo "Avoid problem with unifont during compile of grub..."
# http://savannah.gnu.org/bugs/?40330 and https://bugs.archlinux.org/task/37847
- cp "${srcdir}/unifont-${_UNIFONT_VER}.bdf" "unifont.bdf"
+ gzip -cd "${srcdir}/unifont-${_UNIFONT_VER}.bdf.gz" > "unifont.bdf"
echo "Add the grub-extra sources for BIOS build..."
install -d "grub-extras"
- cp -r "${srcdir}/grub-extras-${_GRUB_EXTRAS_COMMIT}/915resolution" \
+ cp -r "${srcdir}/grub-extras/915resolution" \
"grub-extras/915resolution"
- export GRUB_CONTRIB="${srcdir}/grub-${pkgver}/grub-extras/"
+ export GRUB_CONTRIB="${srcdir}/grub/grub-extras/"
}
_build_grub-efi() {
echo "Copy the source for building the ${_EFI_ARCH} EFI part..."
- cp -r "${srcdir}/grub-${pkgver}" "${srcdir}/grub-${pkgver}-efi-${_EFI_ARCH}"
- cd "${srcdir}/grub-${pkgver}-efi-${_EFI_ARCH}"
+ cp -r "${srcdir}/grub/" "${srcdir}/grub-efi-${_EFI_ARCH}/"
+ cd "${srcdir}/grub-efi-${_EFI_ARCH}/"
echo "Unset all compiler FLAGS for ${_EFI_ARCH} EFI build..."
unset CFLAGS
@@ -204,8 +189,10 @@ _build_grub-efi() {
unset LDFLAGS
unset MAKEFLAGS
- echo "Run autogen.sh for ${_EFI_ARCH} EFI build..."
- ./autogen.sh
+ echo "Run bootstrap for ${_EFI_ARCH} EFI build..."
+ ./bootstrap \
+ --gnulib-srcdir="${srcdir}/gnulib/" \
+ --no-git
echo "Run ./configure for ${_EFI_ARCH} EFI build..."
./configure \
@@ -221,8 +208,8 @@ _build_grub-efi() {
_build_grub-xen() {
echo "Copy the source for building the ${_XEN_ARCH} XEN part..."
- cp -r "${srcdir}/grub-${pkgver}" "${srcdir}/grub-${pkgver}-xen-${_XEN_ARCH}"
- cd "${srcdir}/grub-${pkgver}-xen-${_XEN_ARCH}"
+ cp -r "${srcdir}/grub/" "${srcdir}/grub-xen-${_XEN_ARCH}/"
+ cd "${srcdir}/grub-xen-${_XEN_ARCH}/"
echo "Unset all compiler FLAGS for ${_XEN_ARCH} XEN build..."
unset CFLAGS
@@ -231,8 +218,10 @@ _build_grub-xen() {
unset LDFLAGS
unset MAKEFLAGS
- echo "Run autogen.sh for ${_XEN_ARCH} XEN build..."
- ./autogen.sh
+ echo "Run bootstrap for ${_XEN_ARCH} XEN build..."
+ ./bootstrap \
+ --gnulib-srcdir="${srcdir}/gnulib/" \
+ --no-git
echo "Run ./configure for ${_XEN_ARCH} XEN build..."
./configure \
@@ -255,8 +244,8 @@ _build_grub-bios() {
fi
echo 'Copy the source for building the BIOS part...'
- cp -r "${srcdir}/grub-${pkgver}" "${srcdir}/grub-${pkgver}-bios"
- cd "${srcdir}/grub-${pkgver}-bios"
+ cp -r "${srcdir}/grub/" "${srcdir}/grub-bios/"
+ cd "${srcdir}/grub-bios/"
echo 'Unset all compiler FLAGS for BIOS build...'
unset CFLAGS
@@ -265,8 +254,10 @@ _build_grub-bios() {
unset LDFLAGS
unset MAKEFLAGS
- echo 'Run autogen.sh for BIOS build...'
- ./autogen.sh
+ echo 'Run bootstrap for BIOS build...'
+ ./bootstrap \
+ --gnulib-srcdir="${srcdir}/gnulib/" \
+ --no-git
echo 'Run ./configure for BIOS build...'
./configure \
@@ -282,8 +273,8 @@ _build_grub-bios() {
_build_grub-qemu() {
echo 'Copy the source for building the QEMU part...'
- cp -r "${srcdir}/grub-${pkgver}" "${srcdir}/grub-${pkgver}-qemu"
- cd "${srcdir}/grub-${pkgver}-qemu"
+ cp -r "${srcdir}/grub/" "${srcdir}/grub-qemu/"
+ cd "${srcdir}/grub-qemu/"
echo 'Unset all compiler FLAGS for QEMU build...'
unset CFLAGS
@@ -292,8 +283,10 @@ _build_grub-qemu() {
unset LDFLAGS
unset MAKEFLAGS
- echo 'Run autogen.sh for QEMU build...'
- ./autogen.sh
+ echo 'Run bootstrap for QEMU build...'
+ ./bootstrap \
+ --gnulib-srcdir="${srcdir}/gnulib/" \
+ --no-git
echo 'Run ./configure for QEMU build...'
./configure \
@@ -310,8 +303,8 @@ _build_grub-qemu() {
_build_grub-ieee1275() {
echo 'Copy the source for building the IEEE1275 (OpenFirmware) part...'
- cp -r "${srcdir}/grub-${pkgver}" "${srcdir}/grub-${pkgver}-ieee1275"
- cd "${srcdir}/grub-${pkgver}-ieee1275"
+ cp -r "${srcdir}/grub/" "${srcdir}/grub-ieee1275/"
+ cd "${srcdir}/grub-ieee1275/"
echo 'Unset all compiler FLAGS for IEEE1275 (OpenFirmware) build...'
unset CFLAGS
@@ -320,8 +313,10 @@ _build_grub-ieee1275() {
unset LDFLAGS
unset MAKEFLAGS
- echo 'Run autogen.sh for IEEE1275 (OpenFirmware) build...'
- ./autogen.sh
+ echo 'Run bootstrap for IEEE1275 (OpenFirmware) build...'
+ ./bootstrap \
+ --gnulib-srcdir="${srcdir}/gnulib/" \
+ --no-git
echo 'Run ./configure for IEEE1275 (OpenFirmware) build...'
./configure \
@@ -337,8 +332,8 @@ _build_grub-ieee1275() {
_build_grub-libreboot() {
echo 'Copy the source for building the Libreboot part...'
- cp -r "${srcdir}/grub-${pkgver}" "${srcdir}/grub-${pkgver}-libreboot"
- cd "${srcdir}/grub-${pkgver}-libreboot"
+ cp -r "${srcdir}/grub/" "${srcdir}/grub-libreboot/"
+ cd "${srcdir}/grub-libreboot/"
echo 'Unset all compiler FLAGS for Libreboot build...'
unset CFLAGS
@@ -347,8 +342,10 @@ _build_grub-libreboot() {
unset LDFLAGS
unset MAKEFLAGS
- echo 'Run autogen.sh for Libreboot build...'
- ./autogen.sh
+ echo 'Run bootstrap for Libreboot build...'
+ ./bootstrap \
+ --gnulib-srcdir="${srcdir}/gnulib/" \
+ --no-git
echo 'Run ./configure for Libreboot build...'
./configure \
@@ -365,8 +362,8 @@ _build_grub-libreboot() {
_build_grub-multiboot() {
echo 'Copy the source for building the Multiboot part...'
- cp -r "${srcdir}/grub-${pkgver}" "${srcdir}/grub-${pkgver}-multiboot"
- cd "${srcdir}/grub-${pkgver}-multiboot"
+ cp -r "${srcdir}/grub/" "${srcdir}/grub-multiboot/"
+ cd "${srcdir}/grub-multiboot/"
echo 'Unset all compiler FLAGS for Multiboot build...'
unset CFLAGS
@@ -375,8 +372,10 @@ _build_grub-multiboot() {
unset LDFLAGS
unset MAKEFLAGS
- echo 'Run autogen.sh for Multiboot build...'
- ./autogen.sh
+ echo 'Run bootstrap for Multiboot build...'
+ ./bootstrap \
+ --gnulib-srcdir="${srcdir}/gnulib/" \
+ --no-git
echo 'Run ./configure for Multiboot build...'
./configure \
@@ -392,8 +391,8 @@ _build_grub-multiboot() {
_build_grub-emu() {
echo 'Copy the source for building the emu part...'
- cp -r "${srcdir}/grub-${pkgver}/" "${srcdir}/grub-${pkgver}-emu/"
- cd "${srcdir}/grub-${pkgver}-emu"
+ cp -r "${srcdir}/grub/" "${srcdir}/grub-emu/"
+ cd "${srcdir}/grub-emu/"
echo 'Unset all compiler FLAGS for emu build...'
unset CFLAGS
@@ -402,8 +401,10 @@ _build_grub-emu() {
unset LDFLAGS
unset MAKEFLAGS
- echo 'Run autogen.sh for emu build...'
- ./autogen.sh
+ echo 'Run bootstrap for emu build...'
+ ./bootstrap \
+ --gnulib-srcdir="${srcdir}/gnulib/" \
+ --no-git
echo 'Run ./configure for emu build...'
./configure \
@@ -420,8 +421,8 @@ _build_grub-emu() {
_build_grub-uboot() {
echo "Copy the source for building the U-Boot part..."
- cp -r "${srcdir}/grub-${pkgver}" "${srcdir}/grub-${pkgver}-uboot"
- cd "${srcdir}/grub-${pkgver}-uboot"
+ cp -r "${srcdir}/grub/" "${srcdir}/grub-uboot/"
+ cd "${srcdir}/grub-uboot/"
echo 'Unset all compiler FLAGS for U-Boot build...'
unset CFLAGS
@@ -433,8 +434,10 @@ _build_grub-uboot() {
#sed -i '\|grub_arm_disable_caches_mmu|,+4 d
# ' grub-core/loader/arm/linux.c
- echo 'Run autogen.sh for U-Boot build...'
- ./autogen.sh
+ echo 'Run bootstrap for U-Boot build...'
+ ./bootstrap \
+ --gnulib-srcdir="${srcdir}/gnulib/" \
+ --no-git
echo 'Run ./configure for U-Boot build...'
./configure \
@@ -449,7 +452,7 @@ _build_grub-uboot() {
}
build() {
- cd "${srcdir}/grub-${pkgver}/"
+ cd "${srcdir}/grub/"
if [[ "${CARCH}" = 'x86_64' ]] || [[ "${CARCH}" = 'i686' ]] || [[ "${CARCH}" = 'armv7h' ]]; then
echo "Build grub ${_EFI_ARCH} EFI stuff..."
@@ -498,7 +501,7 @@ build() {
}
_package_grub-efi() {
- cd "${srcdir}/grub-${pkgver}-efi-${_EFI_ARCH}/"
+ cd "${srcdir}/grub-efi-${_EFI_ARCH}/"
echo "Run make install for ${_EFI_ARCH} EFI build..."
make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
@@ -510,7 +513,7 @@ _package_grub-efi() {
}
_package_grub-xen() {
- cd "${srcdir}/grub-${pkgver}-xen-${_XEN_ARCH}/"
+ cd "${srcdir}/grub-xen-${_XEN_ARCH}/"
echo "Run make install for ${_XEN_ARCH} XEN build..."
make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
@@ -522,7 +525,7 @@ _package_grub-xen() {
}
_package_grub-bios() {
- cd "${srcdir}/grub-${pkgver}-bios/"
+ cd "${srcdir}/grub-bios/"
echo 'Run make install for BIOS build...'
make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
@@ -534,7 +537,7 @@ _package_grub-bios() {
}
_package_grub-qemu() {
- cd "${srcdir}/grub-${pkgver}-qemu/"
+ cd "${srcdir}/grub-qemu/"
echo 'Run make install for QEMU build...'
make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
@@ -546,7 +549,7 @@ _package_grub-qemu() {
}
_package_grub-ieee1275() {
- cd "${srcdir}/grub-${pkgver}-ieee1275/"
+ cd "${srcdir}/grub-ieee1275/"
echo 'Run make install for IEEE1275 (OpenFirmware) build...'
make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
@@ -558,7 +561,7 @@ _package_grub-ieee1275() {
}
_package_grub-libreboot() {
- cd "${srcdir}/grub-${pkgver}-libreboot/"
+ cd "${srcdir}/grub-libreboot/"
echo 'Run make install for Libreboot build...'
make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
@@ -570,7 +573,7 @@ _package_grub-libreboot() {
}
_package_grub-multiboot() {
- cd "${srcdir}/grub-${pkgver}-multiboot/"
+ cd "${srcdir}/grub-multiboot/"
echo 'Run make install for Multiboot build...'
make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
@@ -582,7 +585,7 @@ _package_grub-multiboot() {
}
_package_grub-emu() {
- cd "${srcdir}/grub-${pkgver}-emu/"
+ cd "${srcdir}/grub-emu/"
echo 'Run make install for emu build...'
make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
@@ -594,7 +597,7 @@ _package_grub-emu() {
}
_package_grub-uboot() {
- cd "${srcdir}/grub-${pkgver}-uboot/"
+ cd "${srcdir}/grub-uboot/"
echo 'Run make install for U-Boot build...'
make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
@@ -617,7 +620,7 @@ package_grub() {
'sdl: For grub-emu SDL support')
fi
- cd "${srcdir}/grub-${pkgver}/"
+ cd "${srcdir}/grub/"
if [[ "${CARCH}" = 'x86_64' ]] || [[ "${CARCH}" = 'i686' ]] || [[ "${CARCH}" = 'armv7h' ]]; then
echo "Package grub ${_EFI_ARCH} EFI stuff..."
@@ -675,9 +678,8 @@ package_grub-am335x_bone() {
'mtools: For grub-mkrescue FAT FS support')
echo "Copy the source for packaging the U-Boot (am335x-bone) part..."
- cp -r "${srcdir}/grub-${pkgver}-uboot" "${srcdir}/grub-${pkgver}-uboot_am335x-bone"
-
- cd "${srcdir}/grub-${pkgver}-uboot_am335x-bone/"
+ cp -r "${srcdir}/grub-uboot/" "${srcdir}/grub-uboot_am335x-bone/"
+ cd "${srcdir}/grub-uboot_am335x-bone/"
echo 'Patch to detect am335x-bone device tree blob file (dtb)...'
patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-am335x_bone+am335x_boneblack-devicetree-file.patch"
@@ -709,9 +711,8 @@ package_grub-omap3_beagle() {
'mtools: For grub-mkrescue FAT FS support')
echo "Copy the source for packaging the U-Boot (omap3_beagle) part..."
- cp -r "${srcdir}/grub-${pkgver}-uboot" "${srcdir}/grub-${pkgver}-uboot_omap3_beagle"
-
- cd "${srcdir}/grub-${pkgver}-uboot_omap3_beagle/"
+ cp -r "${srcdir}/grub-uboot/" "${srcdir}/grub-uboot_omap3_beagle/"
+ cd "${srcdir}/grub-uboot_omap3_beagle/"
echo 'Patch to detect omap3_beagle device tree blob file (dtb)...'
patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-omap3_beagle-devicetree-file.patch"
@@ -743,9 +744,8 @@ package_grub-omap3_beagle_xm() {
'mtools: For grub-mkrescue FAT FS support')
echo "Copy the source for packaging the U-Boot (omap3_beagle_xm) part..."
- cp -r "${srcdir}/grub-${pkgver}-uboot" "${srcdir}/grub-${pkgver}-uboot_omap3_beagle_xm"
-
- cd "${srcdir}/grub-${pkgver}-uboot_omap3_beagle_xm/"
+ cp -r "${srcdir}/grub-uboot/" "${srcdir}/grub-uboot_omap3_beagle_xm/"
+ cd "${srcdir}/grub-uboot_omap3_beagle_xm/"
echo 'Patch to detect omap3_beagle_xm device tree blob file (dtb)...'
patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-omap3_beagle_xm-devicetree-file.patch"
@@ -777,9 +777,8 @@ package_grub-omap3_beagle_xm_ab() {
'mtools: For grub-mkrescue FAT FS support')
echo "Copy the source for packaging the U-Boot (omap3_beagle_xm_ab) part..."
- cp -r "${srcdir}/grub-${pkgver}-uboot" "${srcdir}/grub-${pkgver}-uboot_omap3_beagle_xm_ab"
-
- cd "${srcdir}/grub-${pkgver}-uboot_omap3_beagle_xm_ab/"
+ cp -r "${srcdir}/grub-uboot/" "${srcdir}/grub-uboot_omap3_beagle_xm_ab/"
+ cd "${srcdir}/grub-uboot_omap3_beagle_xm_ab/"
echo 'Patch to detect omap3_beagle_xm_ab device tree blob file (dtb)...'
patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-omap3_beagle_xm_ab-devicetree-file.patch"
@@ -810,9 +809,8 @@ package_grub-udoo() {
'mtools: For grub-mkrescue FAT FS support')
echo "Copy the source for packaging the U-Boot (udoo) part..."
- cp -r "${srcdir}/grub-${pkgver}-uboot" "${srcdir}/grub-${pkgver}-uboot_udoo"
-
- cd "${srcdir}/grub-${pkgver}-uboot_udoo/"
+ cp -r "${srcdir}/grub-uboot/" "${srcdir}/grub-uboot_udoo/"
+ cd "${srcdir}/grub-uboot_udoo/"
echo 'Patch to detect udoo device tree blob file (dtb)...'
patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-udoo-devicetree-file.patch"