summaryrefslogtreecommitdiff
path: root/libre/grub/PKGBUILD
diff options
context:
space:
mode:
authorLuke T. Shumaker <lukeshu@parabola.nu>2024-01-07 17:17:30 -0700
committerLuke T. Shumaker <lukeshu@parabola.nu>2024-01-13 19:07:53 -0700
commite569121bd500127753070dadbabd8ecd4fda324a (patch)
tree4ca0ae5109673836f71a3cc192bb74d5989c81d7 /libre/grub/PKGBUILD
parent3bebbe97a48eac34e4a215fdc20d31e2d6c30fb6 (diff)
libre/grub: Merge changes from Arch; upgpkg 2.06→2.12
Diffstat (limited to 'libre/grub/PKGBUILD')
-rw-r--r--libre/grub/PKGBUILD57
1 files changed, 38 insertions, 19 deletions
diff --git a/libre/grub/PKGBUILD b/libre/grub/PKGBUILD
index 5491fb630..d47c586b8 100644
--- a/libre/grub/PKGBUILD
+++ b/libre/grub/PKGBUILD
@@ -90,18 +90,17 @@ fi
pkgdesc='GNU GRand Unified Bootloader (2)'
pkgdesc+=', (Parabola rebranded)'
epoch=2
-_tag='53c5000739db114c229fe69ec3d4b76b92441098' # git rev-parse grub-${_pkgver}
-_gnulib_commit='be584c56eb1311606e5ea1a36363b97bddb6eed3'
-_unifont_ver='13.0.06'
-_pkgver=2.06
+_tag='03e6ea18f6f834f177cad017279bedbb0a3de594' # git rev-parse grub-${_pkgver}
+_pkgver=2.12
+_unifont_ver='15.1.04'
pkgver=${_pkgver/-/}
pkgrel=1
-pkgrel+=.parabola2
+pkgrel+=.parabola1
url='https://www.gnu.org/software/grub/'
arch=('x86_64')
arch+=('i686')
arch+=('armv7h')
-license=('GPL3')
+license=('GPL-3.0-or-later')
backup=('etc/default/grub'
'etc/grub.d/40_custom')
install="${pkgname}.install"
@@ -119,11 +118,12 @@ if [[ "${CARCH}" = 'armv7h' ]]; then
fi
makedepends=('git' 'rsync' 'xz' 'freetype2' 'ttf-dejavu' 'python' 'autogen'
- 'texinfo' 'help2man' 'gettext' 'device-mapper' 'fuse2')
+ 'texinfo' 'help2man' 'gettext' 'device-mapper' 'fuse3')
depends=('sh' 'xz' 'gettext' 'device-mapper')
optdepends=('freetype2: For grub-mkfont usage'
- 'fuse2: For grub-mount usage'
+ 'fuse3: For grub-mount usage'
#'dosfstools: For grub-mkrescue FAT FS and EFI support' # drop 'and EFI' from the device-specific arm-uboot packages
+ 'lzop: For grub-mkrescue LZO support'
#'efibootmgr: For grub-install EFI support' # drop from the device-specific arm-uboot packages
#'libisoburn: Provides xorriso for generating grub rescue iso using grub-mkrescue' # drop from the device-specific arm-uboot packages
'os-prober: To detect other OSes when generating grub.cfg in BIOS systems'
@@ -144,12 +144,14 @@ validpgpkeys=('E53D497F3FA42AD8C9B4D1E835A93B74E82E4209' # Vladimir 'phcoder' S
'95D2E9AB8740D8046387FD151A09227B1F435A33') # Paul Hardy <unifoundry@unifoundry.com>
source=("git+https://git.savannah.gnu.org/git/grub.git#tag=${_tag}?signed"
- "git+https://git.savannah.gnu.org/git/gnulib.git#commit=${_gnulib_commit}"
+ 'git+https://git.savannah.gnu.org/git/gnulib.git'
"https://ftp.gnu.org/gnu/unifont/unifont-${_unifont_ver}/unifont-${_unifont_ver}.bdf.gz"{,.sig}
'0001-00_header-add-GRUB_COLOR_-variables.patch'
'0002-10_linux-20_linux_xen-detect-parabola-initramfs.patch'
- '0003-10_linux-20_linux_xen-rebrand-free-distros.patch'
- 'grub.default')
+ '0003-support-dropins-for-default-configuration.patch'
+ '0004-10_linux-20_linux_xen-rebrand-free-distros.patch'
+ 'grub.default'
+ 'sbat.csv')
source_armv7h=(
'1000-am335x_bone--10_linux-20_linux_xen-detect-devicetree-file.patch'
'1000-omap3_beagle--10_linux-20_linux_xen-detect-devicetree-file.patch'
@@ -159,12 +161,14 @@ source_armv7h=(
sha256sums=('SKIP'
'SKIP'
- 'b7668a5d498972dc4981250c49f83601babce797be19b4fdd0f2f1c6cfbd0fc5'
+ '88e00954b10528407e62e97ce6eaa88c847ebfd9a464cafde6bf55c7e4eeed54'
'SKIP'
- '5dee6628c48eef79812bb9e86ee772068d85e7fcebbd2b2b8d1e19d24eda9dab'
- 'b32a28cb5b97b0bb139c0ee2199b81a2aba124c2ead9b01cfd4485fd2551257f'
- '7374137d183957ec8834ce749163c9fa98ff8ee61bbb74b0b38e29daf93857a4'
- 'ed6cf7d8efc391b9331322e4502f7469473a8ed05599c36e2b18f167b3cb7879')
+ 'c25a09792ad97ca93ff385f1821b8c071b28d0ee86c1c4af9365cc00dc5b2b12'
+ '1dd3df0838f9aa737beb0298b855bc93b07d8f3926460ccb8b8f30f5fece3abf'
+ 'a096658d0f48a8b8d0d526d679c2106d0a5bf2a5afb6f2ca7e37f1f2ac33fd85'
+ '281a5225d68be7c230ff2d8175d920bf507439f3fc42cbe866fc31530a1465d3'
+ 'c7c38d62c1238671a09094ceb71befc3fe3873f18343ef0a6f3089d9576dbd43'
+ '50cab883c2412bb583c0521ed34e75aa080ccfc50826ab9d02a4db250ae5c05e')
sha256sums_armv7h=('0f2e9abaf872e1e18dfe0cd1da42bdc4f49d3956f97a01c39b82c0e3016c1a32'
'c0d84384db273d9fd6ea2aab2a9d8ba36402daf8daf591dcba329cfa02253c87'
'ef105dcc067c673e543d4d5384aa7bf6b93e9eca96fec4323ab69a91ec079f56'
@@ -174,10 +178,13 @@ sha256sums_armv7h=('0f2e9abaf872e1e18dfe0cd1da42bdc4f49d3956f97a01c39b82c0e3016c
_backports=(
)
+_reverts=(
+)
+
_configure_options=(
+ PACKAGE_VERSION="${epoch}:${pkgver}-${pkgrel}"
FREETYPE="pkg-config freetype2"
BUILD_FREETYPE="pkg-config freetype2"
- --enable-mm-debug
--enable-nls
--enable-device-mapper
--enable-cache-stats
@@ -207,18 +214,28 @@ prepare() {
git cherry-pick -n "${_c}"
done
+ echo "Apply reverts..."
+ local _c
+ for _c in "${_reverts[@]}"; do
+ git log --oneline -1 "${_c}"
+ git revert -n "${_c}"
+ done
+
echo "Patch to enable GRUB_COLOR_* variables in grub-mkconfig..."
## Based on http://lists.gnu.org/archive/html/grub-devel/2012-02/msg00021.html
- patch -Np1 -i "${srcdir}/0001-00_header-add-GRUB_COLOR_-variables.patch"
+ patch -Np1 -i "${srcdir}/0001-00_header-add-GRUB_COLOR_-variables.patch"
echo "Patch to detect of Parabola GNU/Linux-libre initramfs images by grub-mkconfig..."
patch -Np1 -i "${srcdir}/0002-10_linux-20_linux_xen-detect-parabola-initramfs.patch"
+ echo "Patch to support dropins for default configuration..."
+ patch -Np1 -i "${srcdir}/0003-support-dropins-for-default-configuration.patch"
+
echo "Fix DejaVuSans.ttf location so that grub-mkfont can create *.pf2 files for starfield theme..."
sed 's|/usr/share/fonts/dejavu|/usr/share/fonts/dejavu /usr/share/fonts/TTF|g' -i "configure.ac"
echo "Rebranding for some free distros..."
- patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-rebrand-free-distros.patch"
+ patch -Np1 -i "${srcdir}/0004-10_linux-20_linux_xen-rebrand-free-distros.patch"
echo "Fix mkinitcpio 'rw' FS#36275..."
sed 's| ro | rw |g' -i "util/grub.d/10_linux.in"
@@ -424,6 +441,8 @@ _package_grub-bios() {
_package_grub-efi() {
_package_grub "efi-${_EFI_ARCH}" "${_EFI_ARCH} efi" \
"${_EFI_ARCH}-efi"
+
+ sed -e "s/%PKGVER%/${epoch}:${pkgver}-${pkgrel}/" -e "s/%CARCH%/${CARCH}/" < "${srcdir}/sbat.csv" > "${pkgdir}/usr/share/grub/sbat.csv"
}
_package_grub-emu() {