summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2023-05-25 21:47:58 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2023-05-26 21:21:10 -0400
commit29fc5985e1dbf2858667004a565b868f59bc8b69 (patch)
treeb83403053efb5b725bcf9d15bd067d6924e175de /libre/iceweasel/PKGBUILD
parentc8542ef85cc0bb31f64a04d98054f852361cd208 (diff)
[iceweasel]: build with python 3.10, to support python-pydantic 1.9.2
NOTE: if that python-pydantic problem continues, we may need to package python-pydantic 1.9.2, built against the latest python
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index 4270eb902..1ff1c6eba 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -152,9 +152,7 @@ options=(
source=(
https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
$pkgname.desktop
- identity-icons-brand.svg
- 0001-Bug-1831691-Use-the-vendored-glean_parser-for-all-of.patch
-)
+ identity-icons-brand.svg)
source=(${source[*]/identity-icons-brand.svg/}) # branding over-ride
source+=(
https://repo.parabola.nu/other/iceweasel/${pkgname}_${_brandingver}-${_brandingrel}.branding.tar.xz{,.sig}
@@ -182,8 +180,7 @@ validpgpkeys+=(
)
sha256sums=('7a266044cb9d0c63079b3453507ea0c80a23389f4cbf6a4f6fd15146c6072627'
'SKIP'
- '9cdc2602661717712092d28bb494e5b48e518cb930898aca85eaf21f91f7ef58'
- '1976c0c5e98b0f67e83de778a4fd7729de9b140efa47b77b5879ea2e907987e9')
+ '9cdc2602661717712092d28bb494e5b48e518cb930898aca85eaf21f91f7ef58')
sha256sums+=('a44dc1e9f2d508203d1cacc2b5bb212c73eb04311da9a036560ff389d7b8e9e6'
'SKIP'
'63245fa00363d8884aa2b62fbade557cbe72c5cb326303c7d3f7664e0e3e359c' # 9001-FSDG-sync-remote-settings-with-local-dump.patch
@@ -249,6 +246,7 @@ readonly _SHOULD_USE_GCC==$(case "${CARCH}" in armv7h) echo 1 ;;
makedepends+=( python-pydantic=1.9.2 ) # dustbin - configure error: pydantic 1.10.4 has requirement typing-extensions>=4.2.0, but you have typing-extensions 3.10.0.0
makedepends+=( python-zstandard=0.19.0 ) # dustbin - configure error: zstandard<=0.19.0,>=0.11.1: Installed with unexpected version "0.20.0"
+makedepends+=( python=3.10.10 ) # dustbin - to support 'python-pydantic' above
case "${CARCH}" in
armv7h)
@@ -341,8 +339,6 @@ prepare() {
## technical patching ##
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1831691
- patch -Np1 -i ../0001-Bug-1831691-Use-the-vendored-glean_parser-for-all-of.patch
# arch-specific technical patching
case ${CARCH} in