summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2023-04-15 20:57:04 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2023-06-08 23:03:40 -0400
commit39bc37d5eb92d1bb0b6afc1b1c9edd058e8ea7f7 (patch)
tree2539951b7b7d108ee9c0733cacfc1bb5a37a6a0e /libre/iceweasel/PKGBUILD
parent73e526c0beda7f6c249f7573d654445b8efa76ca (diff)
[icecat][icedove][icewesel]: housekeeping
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD55
1 files changed, 26 insertions, 29 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index 61606213f..e4aa8973b 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -229,16 +229,15 @@ b2sums_i686=('97035e44cd1deae7bb2422c81eec7294feb51f43f460b4d7ddba083e1d8a48d265
## compiler and optimization tweaks ##
-# disable PGO for 32-bit arches (always), x86_64 optionally
-# normally enabled ('0') for x86_64 - try '1' if the build hangs indefinitely
+# disable PGO for 32-bit arches, 64-bit optionally
+# try '1' if the build hangs indefinitely - known past causes:
+# * resource exhaustion
+# * a test which misbehaves in environments without networking
readonly _SHOULD_SKIP_PGO=$(case "${CARCH}" in armv7h|i686) echo 1 ;; *) echo 0 ;; esac)
-# use GCC vs LLVM for 32-bit arches
-# normally not needed ('0') for x86_64
-# for 32-bit arches, try one or the other, to resolve compiler/linker issues
-readonly _SHOULD_USE_GCC==$(case "${CARCH}" in armv7h) echo 1 ;;
- i686 ) echo 0 ;;
- x86_64) echo 0 ;; esac)
+# use GCC vs LLVM for 32-bit arches, 64-bit optionally
+# trying one or the other, may resolve rolling compiler/linker discrepancies
+readonly _SHOULD_USE_GCC=$(case "${CARCH}" in armv7h) echo 1 ;; *) echo 0 ;; esac)
## dependency tweaks ##
@@ -308,23 +307,22 @@ _check_patching() {
# URI protocol handlers
local uri_handlers=uriloader/exthandler/HandlerList.sys.mjs
local webmails='google|yahoo'
+ local misc_err_msg="9003-FSDG-misc.patch needs reworking"
grep 'name:' $uri_handlers | grep '"KiwiIRC",' &> /dev/null && \
! grep 'name:' $uri_handlers | grep -v '"KiwiIRC",' &> /dev/null && \
! grep -E "($webmails)" $uri_handlers &> /dev/null || \
- ! echo "9003-FSDG-misc.patch needs reworking" || \
+ ! echo "${misc_err_msg}" || \
return 1
# services.addons.mozilla.org API endpoint
local amo_api_endpoint='services.addons.mozilla.org'
- ! grep -qr $amo_api_endpoint &> /dev/null || \
- ! echo '9002-FSDG-preference-defaults.patch needs reworking: AMO API endpoint hostname found in source tree' || \
- return 1
+ local amo_err_msg="9002-FSDG-preference-defaults.patch needs reworking: AMO API endpoint hostname found in source tree"
+ ! grep -qr $amo_api_endpoint &> /dev/null || ! echo "${amo_err_msg}" || return 1
# Remote Settings
local settings_server='firefox.settings.services.mozilla.com'
- ! grep -qr $settings_server &> /dev/null || \
- ! echo '9001-FSDG-sync-remote-settings-with-local-dump.patch needs reworking' || \
- return 1
+ local settings_err_msg="9001-FSDG-sync-remote-settings-with-local-dump.patch needs reworking"
+ ! grep -qr $settings_server &> /dev/null || ! echo "${settings_err_msg}" || return 1
popd > /dev/null
}
@@ -457,6 +455,18 @@ EOF
# archarm configuration #
+ # archarm has these over-rides in ## general configuration ## above
+ # NOTE: '--disable-eme' is currently an invalid option for armv7h.
+ # It must be deleted in order to compile.
+ # If ever it becomes valid, it should not be deleted below.
+ sed -i '
+ /--enable-hardening/d
+ /--enable-optimize/d
+ /--enable-rust-simd/d
+ s| --with-wasi-sysroot=.*| --without-wasm-sandboxed-libraries|
+ /--disable-eme/d
+ ' ../mozconfig
+
if [[ $CARCH == "armv7h" ]]; then
echo "ac_add_options --disable-elf-hack" >> .mozconfig
# https://bugzilla.redhat.com/show_bug.cgi?id=1641623
@@ -480,18 +490,6 @@ EOF
# archarm patching is under the 'technical patching' section
- # archarm has these differences in ## general configuration ## above
- # NOTE: '--disable-eme' is currently an invalid option for armv7h.
- # It must be deleted in order to compile.
- # If ever it becomes valid, it should not be deleted below.
- sed -i '
- /--enable-hardening/d
- /--enable-optimize/d
- /--enable-rust-simd/d
- s| --with-wasi-sysroot=.*| --without-wasm-sandboxed-libraries|
- /--disable-eme/d
- ' ../mozconfig
-
# At this point in the recipe (this `case` block), the arch, arch32, and parabola
# PKGBUILDs have prepared a temporary ${srcdir}/mozconfig; but the archarm PKGBUILD
# writes directly to the final firefox-$pkgver/.mozconfig.
@@ -517,8 +515,7 @@ END
# arch32 `export` commands are under the '[ARCH-SPECIFIC BUILD ENV]' section
- # NOTE: these diffs and the compiler flags above, were moved to mozconfig-i686.patch
- # they are more handy to tweak in-line though
+ # NOTE: arch32 has these over-rides and the compiler flags above, in mozconfig-i686.patch
# disable LTO as it has little benefit and uses too many resources
# don't compile with clang, use gcc toolchain (clang has issues on IA32)
# disable SIMD (SSE2 for i686)