summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2024-01-10 22:18:20 -0500
committerbill-auger <mr.j.spam.me@gmail.com>2024-01-19 22:57:12 -0500
commit785a340a61717b199427657446830ee4fe2c9a3b (patch)
tree9c31f6d98475c392b6da20ba5f67664b97790c37 /libre/iceweasel/PKGBUILD
parent0e8ce4fdb41d76c30a1b60bd621747016c0460eb (diff)
iceweasel: minimize diff against upstreams
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD48
1 files changed, 25 insertions, 23 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index 3ea7e58c7..f01bb321f 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -208,26 +208,24 @@ b2sums+=('d6ccdc46fce7cfc4bb35a6b09deee8cd96b9076c599c1f031b4d2c5a9c2722bdf98dd1
'dbb0f9639cbe08bf423faf9e2966b5464a26ab5c6314eea18be0e89edd8ac465bfa04a219821852bdd0801dfed9092999bcca1a982a631035bae9a51408d8dde' # 9003-FSDG-urihandlers.patch
'7d7c9a67ef8035f85482b37d0b7b7743f005d5e7f48d1865f21745ebd10053ed8a6c15e1e176f42d5ef738e7bb074bdad8e912983ca4614a2aab50b95824a4a6' # 9004-FSDG-misc.patch
'6224eb8db58c0d00353512d5bf420a16be90a86dc86c9a8d735026a7f77ca4a8a148fea38015fc9639254b9e02b17d01521ad6b233a890aa082fb8476992fa2f' # process-json-files.py
- 'f3f344196d03499f3f0392d5dfc5310e131d8c85772edd340faf1df3f04ebf2931eb1dda1b7fe6870d61d498618f4d8ae9f1dd446acbe83e0ce324e04b38f3f9' # vendor.js.in
- '6176a2e4b7a651b50b1ca2d6c8b62b1fd7557cacff50f38cb87f126590d9a2ac8d9b249c1671be0551cc81ce9a028a22e9b29ac121e480dab61cd7c10b891d50') # zstandard-0.22.0.diff
+ 'f3f344196d03499f3f0392d5dfc5310e131d8c85772edd340faf1df3f04ebf2931eb1dda1b7fe6870d61d498618f4d8ae9f1dd446acbe83e0ce324e04b38f3f9') # vendor.js.in
b2sums_i686=('684559d207d33e8b83c70d79ddb8b4d7532f2440895668245856553e02b6c786cf0de776981cdcce2438c7add2d692f4afbc85255949558852bdec9800c59882' # avoid-libxul-OOM-python-check.patch
'32c60a9259f9ab6b950c0a3af81e4c36c14160860d3b9da70aa3fbc3676e5fd2b2705b02d7e6b6ac49f9510577de89ab2334abe3b0a126e3d70e65ac42ba62c9' # rust-static-disable-network-test-on-static-libraries.patch
'05c7c9727201971650df4ca2e00539767fc9e159539835c641fccab5ec9577a7294e8f62f5d0670158316e5467ea121c03a36fd4ba153e1d60f3402f0430548d' # firefox-111.0.1-fdlibm.patch
'd20ce3eff595f85df86eaa0dfb665fc356f8987117a771f76adc4ac12046a7e82b0af182fa99f87ea1362a5026c9d0216c7b714649fef0c7294c61c8e8f4d790' # fix-i686-build-moz-1792159.patch
'3e6fd4cebe0fd4c250ccf5b04e12b93e5f4cc2d139301316c987cc07a57b4b6b49b830d745520a82f5ac59da8d17f728a3ecce4dccf21804a2d6a256a6f76472') # fix-i686-xsimd-incomplete.patch
-
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys) # anti-feature
# Note: These are for Arch Linux use ONLY. For your own distribution, please # anti-feature
# get your own set of keys. Feel free to contact foutrelis@archlinux.org for # anti-feature
# more information. # anti-feature
-# _google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM # anti-feature
+_google_api_key= # anti-feature
# Mozilla API keys (see https://location.services.mozilla.com/api) # anti-feature
# Note: These are for Arch Linux use ONLY. For your own distribution, please # anti-feature
# get your own set of keys. Feel free to contact heftig@archlinux.org for # anti-feature
# more information. # anti-feature
-# _mozilla_api_key=e05d56db0a694edc8b5aaebda3f2db6a # anti-feature
+_mozilla_api_key= # anti-feature
## compiler and optimization tweaks ##
@@ -403,8 +401,8 @@ prepare() {
## general configuration ##
- # echo -n "$_google_api_key" >google-api-key # anti-feature
- # echo -n "$_mozilla_api_key" >mozilla-api-key # anti-feature
+ echo -n "$_google_api_key" >google-api-key
+ echo -n "$_mozilla_api_key" >mozilla-api-key
cat >../mozconfig <<END
ac_add_options --enable-application=browser
@@ -579,15 +577,16 @@ END
for size in 16 22 24 32 48 64 128 256
do rsvg-convert -w ${size} -h ${size} iceweasel_icon.svg -o default${size}.png
done
- cp iceweasel_logo.svg content/aboutlogins.svg
- cp iceweasel_logo.svg content/about-logo.svg
-# cp iceweasel_logo.svg content/about-logo.svg # RuntimeError: File "about-logo.svg" not found in browser/branding/iceweasel/content
- rsvg-convert -w 192 --keep-aspect-ratio iceweasel_logo.svg -o content/about-logo.png
- rsvg-convert -w 384 --keep-aspect-ratio iceweasel_logo.svg -o content/about-logo@2x.png
- cp content/about-logo.png content/about-logo-private.png
- cp content/about-logo@2x.png content/about-logo-private@2x.png
- echo "${blank_svg}" > content/$pkgname-symbolic.svg # TODO: branding package
- cp ../unofficial/document.ico document.ico
+ cp iceweasel_logo.svg content/aboutlogins.svg
+ cp iceweasel_logo.svg content/about-logo.svg
+# cp iceweasel_logo.svg content/about-logo.svg # RuntimeError: File "about-logo.svg" not found in browser/branding/iceweasel/content
+ rsvg-convert -w 192 --keep-aspect-ratio iceweasel_logo.svg -o content/about-logo.png
+ rsvg-convert -w 384 --keep-aspect-ratio iceweasel_logo.svg -o content/about-logo@2x.png
+ cp content/about-logo.png content/about-logo-private.png
+ cp content/about-logo@2x.png content/about-logo-private@2x.png
+ echo "${blank_svg}" > content/$pkgname-symbolic.svg # TODO: branding package
+ cp content/${pkgname}-symbolic.svg "${srcdir}"/identity-icons-brand.svg # minimize diff (in package())
+ cp ../unofficial/document.ico document.ico
popd > /dev/null
@@ -701,10 +700,11 @@ build() {
## build env ##
- export MOZ_NOSPAM=1
+ export MACH_BUILD_PYTHON_NATIVE_PACKAGE_SOURCE=system # parabola policy
export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
+ export MOZ_BUILD_DATE="$(date -u${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH} +%Y%m%d%H%M%S)"
# export MOZ_ENABLE_FULL_SYMBOLS=1 # anti-feature
- export MACH_BUILD_PYTHON_NATIVE_PACKAGE_SOURCE=system # parabola policy
+ export MOZ_NOSPAM=1
# malloc_usable_size is used in various parts of the codebase
CFLAGS="${CFLAGS/_FORTIFY_SOURCE=3/_FORTIFY_SOURCE=2}"
@@ -870,8 +870,8 @@ app.distributor.channel=$pkgname
app.partner.parabola=parabola
END
- # NOTE: browser/branding/$theme is $branding_destdir in prepare()
- local i theme=$pkgname
+ local i theme=official
+ theme=$pkgname # NOTE: browser/branding/$theme is $branding_destdir in prepare()
for i in 16 22 24 32 48 64 128 256; do
install -Dvm644 browser/branding/$theme/default$i.png \
"$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/$pkgname.png"
@@ -882,7 +882,7 @@ END
"$pkgdir/usr/share/icons/hicolor/384x384/apps/$pkgname.png"
install -Dvm644 browser/branding/$theme/content/about-logo.svg \
"$pkgdir/usr/share/icons/hicolor/scalable/apps/$pkgname.svg"
- install -Dvm644 browser/branding/$theme/content/$pkgname-symbolic.svg \
+ install -Dvm644 ../identity-icons-brand.svg \
"$pkgdir/usr/share/icons/hicolor/symbolic/apps/$pkgname-symbolic.svg"
install -Dvm644 ../$pkgname.desktop \
@@ -891,8 +891,9 @@ END
# Install a wrapper to avoid confusion about binary path
install -Dvm755 /dev/stdin "$pkgdir/usr/bin/$pkgname" <<END
#!/bin/sh
-exec /usr/lib/$pkgname/$pkgname "\$@"
+exec /usr/lib/$pkgname/firefox "\$@"
END
+ sed -i "s|/firefox |/${pkgname} |" "$pkgdir/usr/bin/$pkgname" # minimize diff
## [ARCH-SPECIFIC INSTALL] ##
@@ -913,7 +914,8 @@ END
# Replace duplicate binary with wrapper
# https://bugzilla.mozilla.org/show_bug.cgi?id=658850
- ln -srfv "$pkgdir/usr/bin/$pkgname" "$pkgdir/usr/lib/$pkgname/$pkgname-bin"
+ ln -srfv "$pkgdir/usr/bin/$pkgname" "$pkgdir/usr/lib/$pkgname/firefox-bin"
+ mv "$pkgdir/usr/lib/$pkgname/firefox-bin" "$pkgdir/usr/lib/$pkgname/$pkgname-bin" # minimize diff
# Use system certificates
local nssckbi="$pkgdir/usr/lib/$pkgname/libnssckbi.so"