summaryrefslogtreecommitdiff
path: root/nonprism/your-privacy/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2024-01-03 12:57:05 -0500
committerbill-auger <mr.j.spam.me@gmail.com>2024-01-06 18:57:31 -0500
commit61260dd92b3f6e05c1a3e949db89fcd9008ebe01 (patch)
treecdf0283dfde89d188e14509d2c606c90f2182d2d /nonprism/your-privacy/PKGBUILD
parent0f1133252b7ed9b62426fb247d82854bdcec84ef (diff)
[your-freedom][your-gaming-freedom][your-privacy][your-init-freedom]: normalize related recipes
Diffstat (limited to 'nonprism/your-privacy/PKGBUILD')
-rw-r--r--nonprism/your-privacy/PKGBUILD23
1 files changed, 10 insertions, 13 deletions
diff --git a/nonprism/your-privacy/PKGBUILD b/nonprism/your-privacy/PKGBUILD
index 42c51e3f2..d234981a0 100644
--- a/nonprism/your-privacy/PKGBUILD
+++ b/nonprism/your-privacy/PKGBUILD
@@ -6,25 +6,26 @@
# The package is normally built automatically by the auto-builder.
# To generate a new package, simply push changes to blacklist.git.
# If ${pkgname}-blacklist.txt is modified, the auto-builder will
-# replace $pkgver, $_gitver, and the checksum (updpkgsums),
+# replace $pkgver, $_srcver, and the checksum (updpkgsums),
# build and publish the package, and commit the changes to abslibre.
pkgname=your-privacy
pkgver=20221006
pkgrel=2
-_gitver=ab32447a5a47a2a5ec5a3fa6043dc6b9024e3674
+_srcver=ab32447a5a47a2a5ec5a3fa6043dc6b9024e3674
pkgdesc="This package will remove support for protocols and services known to endanger privacy."
arch=(any)
url=https://wiki.parabola.nu/Blacklist
-license=(GPL3)
+license=(custom:CCPL:zero)
+# license=('CCPL:zero') # TODO: NYI
makedepends=(librelib)
backup=(etc/NetworkManager/conf.d/20-connectivity.conf)
install=${pkgname}.install
-
-source=(${pkgname}-blacklist-${_gitver}.txt::https://git.parabola.nu/blacklist.git/plain/${pkgname}-blacklist.txt?id=${_gitver}
- archlinux-keyring.hook)
+_srcname=${pkgname}-blacklist-${_srcver}.txt
+source=(${_srcname}::https://git.parabola.nu/blacklist.git/plain/blacklist.txt?id=${_srcver})
+source+=(archlinux-keyring.hook)
sha512sums=('9ab837a9ca351bb844ecdfc147d69ec1f0d1971fbe12ceeed3b837fc59c54b10d2476901e60f677b0f53166a805b493b0a8bcd638e9e6638012dd454c7930cf8'
'864b419e3aec86adc3ee2cc49ccba69e209f53cf174e889f25c21b0f0813760432e98e7eb024d30376163efec2a6e6d2693a871d895d7de5133bcd2f4df9626b')
@@ -32,15 +33,11 @@ sha512sums=('9ab837a9ca351bb844ecdfc147d69ec1f0d1971fbe12ceeed3b837fc59c54b10d24
package()
{
- local blacklist_file=${pkgname}-blacklist-${_gitver}.txt
-
# collect blacklisted package names as pacman conflicts
- conflicts=( $( libreblacklist normalize < ${blacklist_file} | \
- cut -d: -f1,2 | \
- sed -n 's/:$//p' | \
- sort -u ) )
+ conflicts=( $( libreblacklist normalize < ${_srcname} | \
+ cut -d: -f1,2 | sed -n 's/:$//p' | sort -u ) )
- install -Dm644 ${blacklist_file} "${pkgdir}"/usr/share/doc/${pkgname}/blacklist.txt
+ install -Dm644 ${_srcname} "${pkgdir}"/usr/share/doc/${pkgname}/blacklist.txt
# disable automatic archlinux-keyring refresh
install -Dm644 archlinux-keyring.hook "${pkgdir}"/usr/share/libalpm/hooks/archlinux-keyring.hook