summaryrefslogtreecommitdiff
path: root/libre/iceweasel-ublock-origin/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/iceweasel-ublock-origin/PKGBUILD')
-rw-r--r--libre/iceweasel-ublock-origin/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/libre/iceweasel-ublock-origin/PKGBUILD b/libre/iceweasel-ublock-origin/PKGBUILD
new file mode 100644
index 000000000..16d69bc39
--- /dev/null
+++ b/libre/iceweasel-ublock-origin/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: André Silva <emulatorman@parabola.nu>
+
+pkgname=iceweasel-ublock-origin
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="Extension fork of the Adblock Plus for Iceweasel which block ads and banners, but without 'acceptable ads' feature"
+arch=('any')
+url="https://github.com/gorhill/uBlock"
+license=('GPL3')
+groups=('iceweasel-addons')
+depends=("iceweasel")
+makedepends=('unzip')
+provides=('iceweasel-adblock-plus')
+conflicts=('iceweasel-adblock-plus')
+replaces=('firefox-adblock-plus' 'iceweasel-adblock-plus')
+source=("https://github.com/gorhill/uBlock/releases/download/$pkgver/uBlock0.firefox.xpi")
+md5sums=('9f907a1d2e845cd34acfb5a669c013ac')
+
+package() {
+ # extension
+ _dest="$pkgdir/usr/lib/iceweasel/browser/extensions/uBlock0@raymondhill.net"
+ find . -type d -exec install -d {} $_dest/{} \;
+ find . -type f -exec install -Dm644 {} $_dest/{} \;
+
+ # license
+ install -Dm644 LICENSE.txt \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}